Welcome to Canada's Favourite Questions and Answers Community, where you can ask practical questions and get sensible answers from people in your city and province. Do you know an answer? It's free to answer and help someone without the need to register or login.

How to solve err_connection_refused problem with my own question2answer website after logging in the main admin page?

+6 votes
14 views
Whenever i tried to login into my admin page for my own website, i get an error (err_connection-refused), For example, the website www.yourdomain.com refused to connect. I installed a question and answer website and it was working fine for a year until recently this problem started occuring for no reason. The other users for my website seems to be not having any problem accessing my website. Only myself i am facing the error connection refused problem after login into the admin page. The website would refuse to load at all and it usually resets itself after some minutes, hours or even for a day at times. At first when this problem occured i was worried that i might have lost the whole website to some attacks or viruses, but then i realised that i could actually still access my website using my phone data plan. I tried access my website using another computer or phone using the same WIFI network but i still can't access my website.

I came to understand that once this problem occured, any devices connected to the same WIFI network will be affect and will not be able to connect to that website. So i did a bit of a research on this problem and tried some most of the solutions on the internet. People have mentioned that the problem could be linked to the browser Google Chrome or Mozilla Firefox, but the same problem occurs in my smart phone too. So it couldn't be the problem with the internet browser. I also tried changing some settings with my home WIFI internet and clearing the cache and cookies for my internet browser but with no success. I tried flushing the DNS and deselecting the Proxy settings for my Computer network and still the problem remained. This problem had been driving me crazy and i hope someone would be able to offer something useful in solving this problem. Any help would be much appeciated.
asked in Goose Bay by George Bain (133 points)

1 Answer

0 votes
I would like to offer a suggestion and solution to the problem although this solution could potentially reduce a layer of security for your website. The problem is not with your internet browser or your home WIFI internet connection. If you access your website with another phone data plan or someone else's internet connection, you will notice that you can still access your website without any problem. What is happening is that your web hosting services have enabled a feature called "Modsecurity" and this is preventing your website from performing some functions. Every time that you tried to login into your website admin page, some of the scripts codes have been activated and this triggered your web hosting server to shut down access to your website. Your web hosting server thinks that someone is trying to place an attack on your website and in response it prevents any connection between your internet connection and the hosting servers. That is why any devices connected to your home WIFI internet could not access the website meanwhile devices connected to another internet connection which isn't affected, will be fine to access your website.

Login into your website cpanel, and look at the "Security" section of your cpanel. You will find an icon called "Modsecurity". Click on that. Then turn the status of your domain to "Off" position. Now try accessing your own website and you will be surprised to find that it works fine now.
answered by Joni Aleman (107 points)

Related questions

+2 votes
1 answer
+6 votes
1 answer
...